作者: oldwatch

56 篇文章

pip install安装包不安装其他依赖设置
pip install安装包不安装其他依赖设置 最近安装 keras 包时,指定版本后总是会安装其他依赖,特别是会自动安装 tensorflow 最高版本,明明我已经有个tf gpu版本了,却还会给我安装个cpu版本,头疼。 查了下,pip 安装的时候可以指定不安装包对应的其他依赖,设置--no-dependencies即可 。 pip insta…
jupyter 添加/删除kernel
jupyter 添加/删除kernel 查看kerel jupyter kernelspec list 添加kernel # 创建一个新环境 现在我喜欢用conda conda create -n py38 python=3.8 conda activate py38 # 在新环境中安装 ipykernel pip install ipykerne…
jupyterlab/jupyter notebook 上使用ipywidgets和组件不显示问题
jupyterlab/jupyter notebook 上使用ipywidgets 今天给大家分享下最近遇到的一个编程小问题,在jupyterlab下ipywidgets组件无法显示。 首先推荐大家使用conda去管理虚拟环境,这样我们安装系统依赖也可以使用conda会方便很多,而且conda使用不限制系统。 jupyterlab 安装ipywid…
git 团队协作常用命令和流程
git 团队协作常用命令和流程 - git clone 将项目从github/gitee 下载到本地 git clone -b 分支名称 项目git链接 如:git clone -b xxx https://github.com/XksA-me/DingdingBot.git - git add 将当前目录下修改的所有代码从工作区添加到缓存区 gi…
python2.7 nltk无法安装
python2.7 nltk无法安装 首先查看python版本: python --version python3 --version 查看可以安装使用的nltk版本,可以conda search查询: conda search nltk ''' # Name Version Build Channel nltk 3.4 py27_0 anacon…
python如何安装DGL(Deep Graph Library)
python如何安装DGL(Deep Graph Library) 其实很简单,直接前往dgl官网:https://www.dgl.ai/pages/start.html 然后在官网选择自己本地或者服务器对应的环境,如:cuda版本、系统、python版本,推荐使用pip安装方式,选择好后就会出现安装指令,复制安装指令到自己系统中,开启termin…